Como contar células no Microsoft Excel

O Excel fornece vários métodos para contar células, incluindo o uso da função Localizar ou de um filtro. Mas com recursos, você pode contar exatamente o que precisa. De células preenchidas a espaços em branco, de números a texto, veja como contar células no Excel.

índice

  1. Contar células com números: a função COUNT
  2. Contar células em branco: a função COUNTBLANK
  3. Contar células não vazias: a função COUNT
  4. Contar células com critérios específicos: a função CONT.SE

Contar células com números: a função COUNT

Se você quiser contar o número de células que contêm apenas números, você pode usar a função COUNT. A sintaxe da fórmula é: COUNT(value1, value2,...) onde value1 é obrigatório e value2 é opcional.

usa value1 para suas referências de célula, o intervalo de células com o qual você deseja contar. você pode usar value2 (e argumentos subsequentes) para adicionar um número específico ou outro intervalo de células conforme desejado. Vamos dar uma olhada em alguns exemplos.

Para contar o número de células no intervalo A1 a D7 que contêm números, digite o seguinte e pressione Enter:

 =CONTAR(A1:D7) 

Você receberá o resultado na célula que contém a fórmula.

Para contar o número de células em dois intervalos separados B2 a B7 e D2 a D7 que contêm números, digite o seguinte e pressione Enter:

 =CONTAR(B2:B7,D2:D7) 

Agora você verá a contagem total de números para ambos os intervalos de células.

Contar células em branco: a função COUNTBLANK

Talvez o que você queira encontrar seja o número de células em branco que você tem em um determinado intervalo. Use uma variante da função COUNT, COUNTBLANK. A sintaxe da fórmula é: COUNTBLANK(value1) Onde é value1 contém referências de célula e é obrigatório.

Para contar o número de células em branco no intervalo A2 a C11, digite o seguinte e pressione Enter:

 =CONTAR EM BRANCO(A2:C11) 

Então você verá o resultado na célula onde você digitou a fórmula.

Para mais exemplos e usos de COUNTBLANK, confira nosso tutorial sobre contagem de células em branco ou em branco no Excel.

Contar células não vazias: a função COUNT

Talvez você queira fazer exatamente o oposto de contar células em branco e contar células que contêm dados. Neste caso, use a função COUNT. A sintaxe é COUNTA(value1, value2,...) onde value1 é obrigatório e value2 é opcional.

Como a função COUNT acima, value1 é para suas referências de célula e value2 é para quaisquer intervalos adicionais que você deseja incluir.

Para contar o número de células não vazias no intervalo A2 a C11, digite o seguinte e pressione Enter:

 =CONTA(A2:C11) 

Como você pode ver, a função COUNT conta as células que contêm qualquer tipo de dado. Isso inclui números, texto, erros e texto ou strings vazios. Por exemplo, o erro na célula C7 é contado.

Se um erro causar problemas, é fácil ocultar valores de erro em planilhas.

Contar células com critérios específicos: a função CONT.SE

Se você quiser contar o número de células que contêm dados específicos, use a função COUNT. A sintaxe da fórmula é COUNTIF(value1, criteria) onde ambos os criteria value1 E são obrigatórios.

Como as outras funções aqui, value1 contém as referências de célula para o intervalo. Criteria é o item que você deseja pesquisar e pode ser uma referência de célula, palavra, número ou curinga. Vamos dar uma olhada em alguns exemplos básicos.

Para contar o número de células no intervalo C2 a C6 que contêm a palavra "meias", digite o seguinte e pressione Enter:

 =CONT.SE(C2:C6,"meias") 

Observe que se o seu critério for uma palavra, você deve colocá-la entre aspas.

Para contar o número de células no intervalo B2 a C6 que contêm o conteúdo da célula B2, digite o seguinte e pressione Enter:

 =CONT.SE(B2:C6,B2) 

Nesse caso, você não colocaria a referência de célula B2 entre aspas.

Para obter mais exemplos e usos de CONT.SE, consulte nossas instruções para usar CONT.SE no Excel.

Contar células no Microsoft Excel é simples quando você conhece essas funções básicas e como usá-las. Mas se você estiver interessado em algo como destacar lacunas ou erros em vez de apenas contá-los, temos o que você precisa!

  • O aplicativo YouTube TV para de funcionar no Roku e desta vez é um acidente
  • Você pode assistir TikTok em TVs Android, Samsung e LG

descubra mais conteúdo

O que é um amplificador integrado?

Google Pixel Watch também tem detecção de queda, mas não até o próximo ano

As melhores xícaras de café aquecidas de 2022

Como automatizar seu iPhone com base na hora, atividade ou localização

"Isso deve ter sido antes do meu tempo"

Por que a NASA enviou Snoopy para a Lua? – Revisão Geek

Como contar células cheias?

Na guia Fórmulas, clique em Mais Funções, aponte para Estatísticas e clique em uma das seguintes funções:

  1. COUNT: Para contar células que não estão vazias.
  2. COUNT :Para contar as células que contêm números.
  3. CONT .
  4. COUNT .IF: Para contar células que atendem a um critério especificado.

Como contar células preenchidas com texto no Excel?

Os critérios para contagem de células com texto devem estar entre aspas (“”). (Obrigatoriedade). Para definir critérios, podem ser usados ​​sinais como “=”, “>”, “<”. Os curingas são usados ​​para se referir ao texto .

Como contar células que não estão vazias?

Use a função COUNTA para contar apenas as células em um intervalo que contém valores. Ao contar células , às vezes você pode querer ignorar as células em branco porque você só precisa daquelas que contêm valores.

Como contar células contendo uma palavra?

Conte se a célula contiver texto ou parte de texto com a função COUNT .IF

  1. =CONT.SE(B5:B10,"*"&D5&"*")
  2. Sintaxe.
  3. =CONT.SE (intervalo, critérios)
  4. argumentos.
  5. Notas:
  6. =CONT.SE(B5:B10,"*")
  7. Dica.
Ir arriba